SAP Knowledge Base Article - Public

3686473 - Application error for custom tasks with attachment field - Onboarding

Symptom

  • An application error occurs for custom tasks when the custom task includes an attachment.
  • The error message appears for all users, including Admin and HR roles when trying to upload attachment
  • Error message displayed: "There was an application error". Submit Button is greyed out

Environment

SAP Successfactors Onboarding

Reproducing the Issue

  1. Navigate to the Onboarding Dashboard.
  2. Search for affected candidate.
  3. Go to Actions- New Hire Data.
  4. Select “View Details” for the custom task.
  5. Click on "Edit Task".
  6. Unable to submit. Submit button is greyed out
  7. Observe the error message: "There was an application error".

Cause

Go to the object definition within the Externalcode - details, the Required field is set to "Yes". 

Resolution

  1. Verify the configuration of the Required field within the Externalcode field in the object.
  2. Update the Required field within the Externalcode field to "No".

See Also

3406989 - "There was an application error" in custom tasks - Onboarding

Keywords

application,error, custom, task, attachment, field, onboarding, dashboard, external, code, field, task ,submission, submit,button,greyed,out,there was an application error , KBA , LOD-SF-OBX-CDC , Custom Data Collection , Problem

Product

SAP SuccessFactors Onboarding all versions