Symptom
You are facing the error below on CPI.
Error Details
org.apache.camel.CamelExchangeException: Multicast processing failed for number 0. Exchange[2F72141528CEFF1-0000000000000002]. Caused by: [org.apache.camel.CamelExchangeException - Multicast processing failed for number 0. Exchange[2F72141528CEFF1-0000000000000003]. Caused by: [org.apache.camel.component.ahc.AhcOperationFailedException - HTTP operation failed invoking https://my1002011.de1.test.crm.cloud.sap/sap/c4c/api/v1/inbound-data-connector-service/messages/sap.crm.md.integrationmetadataservice.entity.employeeS4ReplicationMessageIn with statusCode: 403]], cause: org.apache.camel.component.ahc.AhcOperationFailedException: HTTP operation failed invoking https://my1002011.de1.test.crm.cloud.sap/sap/c4c/api/v1/inbound-data-connector-service/messages/sap.crm.md.integrationmetadataservice.entity.employeeS4ReplicationMessageIn with statusCode: 403
Environment
- SAP Sales Cloud and SAP Service Cloud Version 2 integration with S/4HANA.
- SAP Sales Cloud and SAP Service Cloud Version 2 integration with ERP.
Reproducing the Issue
In CPI
- Go to Overview.
- Go to "All Integration Flows - Failed messages".
- Search for the message ID: XXXXX
- Check the error message
Error Detailsorg.apache.camel.CamelExchangeException: Multicast processing failed for number 0. Exchange[2F72141528CEFF1-0000000000000002]. Caused by: [org.apache.camel.CamelExchangeException - Multicast processing failed for number 0. Exchange[2F72141528CEFF1-0000000000000003]. Caused by: [org.apache.camel.component.ahc.AhcOperationFailedException - HTTP operation failed invoking https://<mytenant>/sap/c4c/api/v1/inbound-data-connector-service/messages/sap.crm.md.integrationmetadataservice.entity.employeeS4ReplicationMessageIn with statusCode: 403]], cause: org.apache.camel.component.ahc.AhcOperationFailedException: HTTP operation failed invoking https://<mytenant>/sap/c4c/api/v1/inbound-data-connector-service/messages/sap.crm.md.integrationmetadataservice.entity.employeeS4ReplicationMessageIn with statusCode: 403
Cause
Security Policy for the user is setup wrong.
In SSCv2,
- Go to "Settings".
- Go to "User" tab.
- Under "User" tab, filter by Technical Users.
- Open the User ABC.
- Click to check the details and see that the Security Policy is not set as S_TECHNICAL_USER.
Resolution
Set up the Security Policy for this as S_TECHNICAL_USER.
Keywords
statusCode: 403, User Security Policy, S_TECHNICAL_USER. , KBA , CEC-CRM-INT , Integration for SAP Sales/Service Cloud , CEC-CRM-DC , Data Connector for SAP Sales/Service Cloud , How To
Product
SAP Sales Cloud and SAP Service Cloud Version 2 all versions
SAP Knowledge Base Article - Public