Symptom
The sales order item has confirmed quantity in the Monitor BOP Run app without any update issues, but when you check in the Change Sales Order app, there is no confirmed schedule line for the item.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Run the BOP for a specific sales order.
- Find that the sales order has confirmed quantity in the Monitor BOP Run app.
- Check in Change Sales Order app, the item has no confirmed schedule line.
Cause
There is no confirmed schedule line generated in the Change Sales Order app due to the system's automatic credit limit check for sales orders.
Following BOP ATP execution, confirmation information is transferred to the Change Sales Order app. However, when BOP modifies credit check-relevant fields such as confirmed quantities, delivery dates, or pricing adjustments, the system automatically triggers a credit check. If the system finds that the order has a credit block, it removes the confirmed quantities from the schedule lines. And this unconfirmed status is not transferred back to BOP. Consequently, BOP continues to display confirmed quantities while the Change Sales Order app shows no confirmations.
Resolution
The re-triggering of credit checks during BOP ATP is standard behavior.
To avoid such inconsistency, please address the credit-related problems in the affected sales orders, or alternatively, modify the "check credit" field to blank in configuration activity 101518 - Define Automatic Credit Control.
Keywords
101518, Credit block, Change Sales Order, BOP, Confirm quantity, Monitor BOP Run, schedule line, check credit , KBA , CA-ATP-PAC-2CL , ATP: Product Availability Check (Public Cloud) , Problem
SAP Knowledge Base Article - Public