SAP Knowledge Base Article - Public

3686977 - Account dimension filter error in API subscription after QRC4 update in SAP Analytics Cloud

Symptom

  • Account dimension filter is not working in API subscription.
  • Error message displayed: "The accounts can't be loaded due to a technical error. Please contact your administrator."
  • The issue is observed after the QRC4 upgrade.
  • Other dimensions are functioning correctly without any issues.

Environment

SAP Analytics Cloud 2025.21.6

Reproducing the Issue

  1. Open the model.
  2. Navigate to the 'Data Management' tab.
  3. Select API Subscriptions.
  4. Click on '+' to create a new subscription chain.
  5. Select Filter Dimensions, add a filter for Account.
  6. Observe the error message: "The accounts can't be loaded due to a technical error."

Cause

The development team has identified the root cause, and is working on a fix.

Resolution

The solution of this issue is currently under investigation. Please follow this KBA for updates.

See Also

Keywords

account dimension filter error, api subscription issue, qrc4 update, sap analytics cloud, dimensional filter error, data management tab, technical error, API subscription chain, account filter issue , KBA , LOD-ANA-ML-DI , Data Integration, Data Export API, Data Import API , Problem

Product

SAP Analytics Cloud all versions