Symptom
When generating BACS payment files, the SUN ID is correctly picked for one company code but not for another although,
- Both company codes share the same payment method.
- Both use the same payment format.
- Configuration appears identical.
- Mapping via the Map Format Data app is the same.
The resulting payment file for one company code contains the correct SUN ID, while the other payment file shows that the SUN ID is missing.
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Environment
SAP S/4HANA Cloud Public Edition
Cause
The issue occurs due to the configuration in SSCUI 103132 – “Define User Number at Bank in Norway, United Kingdom, and Ireland, the system derives the country from the House Bank, not from the Company Code.
For Example: In below image
- Company Code GI01 → Country = GI.
- House Bank → Country = UK.
Without a configuration entry for the combination of GI01/GI, the SUN ID is not determined correctly
Resolution
To ensure the correct User Number / SUN ID is determined, maintain the required entry in the configuration activity "Define User Number at Bank in Norway, United Kingdom, and Ireland" SSCUI ID - 103132
Steps:
- Open the configuration activity "Define User Number at Bank in Norway, United Kingdom, and Ireland" (SSCUI- 103132).
- Maintain the required combination for the affected company code:
- Company Code: GI01.
- Country: GB (derived from House Bank).
- SUN ID: Enter the correct SUN ID provided by the bank.
- Save the changes.
- Regenerate the payment file.
The system will now pick up the appropriate User Number / SUN ID.
See Also
Keywords
payment file, BACS payment, SUN ID, company code GI01, house bank, SSCUI 103132, sap s/4hana cloud public edition, payment method per country setup, configuration issue, define user number at bank. , KBA , FI-AP-AP-B1 , Payment transfer (w/o DE, US) , Problem
Product
Attachments
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SAP Knowledge Base Article - Public