SAP Knowledge Base Article - Public

3687615 - Automatic renewal error: "Date CONTDURA does not exist" in service contract item renewal - SAP S/4HANA Cloud Public Edition

Symptom

Auto renewal is enabled with the renewal period set as "1 week". The end date of the service contract item is to be expired within 1 week. However, the service contract item is not renewed, with error message "Date CONTDURA does not exist" and information message "No contract items need to be renewed" found in the "Monitor Auto Renewal Logs" app. However, through checking the item-level custom date profile &1, the duration CONTDURA has already been assigned to it.

Environment

SAP S/4HANA Cloud Public Edition

Cause

The root cause lies in that, the required duration CONTDURA is missing in the header-level custom date profile &1 in the configuration activity "Define Date Profile for Service Transactions (ID: 104301)".

Resolution

Add the duration &1 into the header-level custom date profile &2 via the configuration activity "Define Date Profile for Service Transactions (ID: 104301)".

    See Also

    Keywords

    automatic renewal error, service contract renewal, date does not exist, monitor auto renewal logs, sap s/4hana cloud public edition, item contract renewal, auto-renewal issue, contract item duration, renewal period error, dummy changes, header-level date profile, ZCONT001 , KBA , CRM-S4-SRV-CTR-2CL , S4CRM: Service Contract (Public Cloud) , Problem

    Product

    SAP S/4HANA Cloud Public Edition all versions