Symptom
- You are replicating the contact persons from SAP S4HANA Public Cloud or SAP S4HANA Private Cloud through Business Partner Replication interface to SAP Sales & Service Cloud V2.
- You find the email and phone number are seen in the incoming message in V2
- When you open the corresponding Contact - the email and phone number are missing on header
Environment
Integration of SAP Sales/Service Cloud V2 with SAP S4HANA
Reproducing the Issue
- Update email address or phone number of Contact Person in S4HANA
- Check the incoming message in Message Monitoring view of SAP Sales & Service Cloud V2
- When you open the corresponding Contact - the email and phone number are missing on header
Cause
Emails and phone numbers sent via BusinessPartner Replication Incoming message for Contact are considered as HOME/Personal contact details and are not shown on the UI.
Resolution
- Ensure that the email and phone number are sent in the relationship replication message for Account ~ Contact.
- If the contact has only one account associated and if email is available in replication message - then Email is displayed on Contact Header.
- If the contact is linked to multiple accounts, verify that the details from the main account (main indicator enabled) are displayed on the contact header.
- If the main indicator enabled account does not have email or phone number in the association or is not replicated using the relationship replication message, ensure the replication is corrected to display the details on the contact header.
Keywords
s4 public cloud, esm tenant ui, email address not displayed, phone number not displayed, businesspartner replication, relationship replication message, contact header, main account indicator, contact details missing , KBA , CEC-CRM-INT , Integration for SAP Sales/Service Cloud , Problem
Product
SAP Sales Cloud and SAP Service Cloud Version 2 all versions
SAP Knowledge Base Article - Public