Symptom
- The "Add" button is not displayed in the Payment Information portlet on the SuccessFactors mobile app for employees who have not yet recorded payment information.
- The "Add" button is displayed normally when accessing the system via a URL on a PC.
- The issue occurs across all operating systems (iOS and Android) and in both environments (Test and Production).
Environment
- People Profile - Full Profile
Reproducing the Issue
- Access SuccessFactors using the mobile app.
- Navigate to Profile -> Personal Data.
- In the Payment Information portlet, observe that the "Add" button is not displayed.
Cause
- The edit functionality for the Payment Information portlet is not included in the current release (b2511).
Resolution
- The "Add" button functionality is planned for completion in the next release 2605
- Since the "Add" button is part of the edit functionality, it will not appear on the empty Payment Information card until the feature is delivered.
- Refer to the following links for updates on the feature release
Keywords
successfactors mobile app, payment information portlet, add button missing, mobile app issue, iOS, Android, payment info, personal data, people profile, full profile, edit functionality, release b2511, mobTrain-2605, MEX-103, MOB-88432 , KBA , LOD-SF-EP-FPP , People Profile - Full Profile , Problem
Product
SAP SuccessFactors Employee Central all versions
SAP Knowledge Base Article - Public