Symptom
- If a publication fails or is partially successful, the owner of the publication does not receive external email notifications indicating the failure.
- In-app notifications are received for failed publications, but corresponding email notifications are not sent.
Environment
SAP Analytics Cloud 2025.14.12
Reproducing the Issue
- Log in to SAP Analytics Cloud (SAC).
- Create a failed publication for a story.
- Observe that an in-app notification is received for the failed publication, but no email notification is sent.
Cause
Notification reasons under the e-mail column were not properly selected for the owner in the notification settings.
Resolution
- Navigate to System -> Administration -> Notifications -> Edit.
- Under Notification Reason, ensure the following options are selected in the email column:
- "Automatic task failed"
- "Automatic task completed successfully or partially successfully"
- Save the changes.
Please note that after adjusting the above settings, you will only receive E-mails for failed tasks. E-mails for the successfully completed tasks are not sent out and it is by design. However, you will receive an in-app notification for the successful publication tasks as well.
See Also
Refer to: Notification Reasons | SAP Help Portal
Keywords
publication failure, email notification, sap analytics cloud, sac notifications, automatic task failed, automatic task completed, sac publication errors, sac email settings, sac notification settings, sac publication troubleshooting, failed publication email , KBA , LOD-ANA-SCH , SAC Story Scheduling and Publication , LOD-ANA-ADM , SAC Administration , Problem
SAP Knowledge Base Article - Public