SAP Knowledge Base Article - Public

3688647 - Product Name Not Displayed In Registered Product

Symptom

Product name is not displayed in Registered Product OWL and in the detailed view screen.

Environment

SAP Sales Cloud and SAP Service Cloud Version 2

Reproducing the Issue

  1. Go to Registered Products Workcenter.
  2. Open a Registered Product Product in detail view.
  3. In the left pane, notice that the Product field is empty.
  4. Click on Product field.
  5. Notice that in the edit mode of Product field, the Product ID is displayed.

Cause

Description is not maintained in the Product Master Data. The Registered Product UI renders the description directly from the related Product's description field. So when the source field is empty, the Registered Product details show no description. 

Resolution

  1. Go to Products Workcenter.
  2. Open a Product in Detail View.
  3. In the left pane, populate the Description field with a value (if Description field is not available, it can be added via Adaptation Mode).
  4. Once the data is saved, go to the related Registered Product and notice that the Product field will be populated with value.

Keywords

Product, Registered Product, Description, Product ID, Product Description, Detail View, List View, OWL, Blank, Empty, Service, Product Name , KBA , CEC-CRM-RPD , Registered Products for SAP Sales/Service Cloud , CEC-CRM-PRD , Product for SAP Sales/Service Cloud , Problem

Product

SAP Sales Cloud and SAP Service Cloud Version 2 all versions