SAP Knowledge Base Article - Public

3688692 - Application error while approving an Advance Request - Employee Central

Symptom

Last Approver receives an application error when trying to approve an advance request for the employee.

Environment

SAP SuccessFactors Employee Central

Cause

Employee already has an Accumulation for advances record that is incomplete.

Resolution

HR or Admin needs to manually adjust the Accumulation For Advances record for the employee with "Maximum Number of Occurrences".

See Also

2655185 - Error While Applying For A New Advance
3069279 - "You cannot have a recovery with duplicate pay component within the period of this advance." even if installments are paid.

Keywords

"Maximum Number of Occurrences", "Accumulation For Advances", application error, advance request, advance workflow, fingerprint=151b29b957218bb7149c8651065cd9dc9e6e4d55, fingerprint, "151b29b957218bb7149c8651065cd9dc9e6e4d55", "Cannot invoke "java.lang.Long.longValue()" because the return value of "com.successfactors.advancesmanagement.bean.advances.AdvancesAccumulation.getNumberOfOccurances()" is null" , KBA , LOD-SF-EC-ADV , Advances , Problem

Product

SAP SuccessFactors HCM Core 2505