SAP Knowledge Base Article - Public

3689396 - "Error Verify validity dates for recipients" when executing Workflow Rule

Symptom

The Workflow Rule configured to sent e-mails from Ticket is getting failed with error message "Error Verify validity dates for recipients: ABC" (where ABC represents the name of the person).

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Service > Tickets.
  2. Open the desired Ticket.
  3. Go to Workflow Changes tab.
  4. See the rule failed.
  5. Click on Failed log.
  6. Error message "Error Verify validity dates for recipients: ABC" is shown.

Cause

The Workflow Rule is getting failed for the Ticket because one of the recipients have invalid date.

If the Workflow Rule matches the conditions, the rule will be executed, but if the rule is not able to perform its action completely (in this case determine all recipients) the rule will fail.

Resolution

This is the system expected behavior. In order to fix that, please extend the Employees' validity by following:

  1. Go to Administrator > Employees.
  2. Search for the desired Employee and edit it.
  3. Extend the "Valid To" date field.
  4. Save.

Keywords

KBA , LOD-CRM-WKF , Workflow , Problem

Product

SAP Cloud for Customer core applications all versions