Symptom
The Workflow Rule configured to sent e-mails from Ticket is getting failed with error message "Error Verify validity dates for recipients: ABC" (where ABC represents the name of the person).
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Service > Tickets.
- Open the desired Ticket.
- Go to Workflow Changes tab.
- See the rule failed.
- Click on Failed log.
- Error message "Error Verify validity dates for recipients: ABC" is shown.
Cause
The Workflow Rule is getting failed for the Ticket because one of the recipients have invalid date.
If the Workflow Rule matches the conditions, the rule will be executed, but if the rule is not able to perform its action completely (in this case determine all recipients) the rule will fail.
Resolution
This is the system expected behavior. In order to fix that, please extend the Employees' validity by following:
- Go to Administrator > Employees.
- Search for the desired Employee and edit it.
- Extend the "Valid To" date field.
- Save.
Keywords
KBA , LOD-CRM-WKF , Workflow , Problem
SAP Knowledge Base Article - Public