Symptom
Error messages "Please enter a party with role Sender" and "Please enter a party with role Employee Responsible" are displayed when using E-mail in Tickets. For example, there is a custom logic for e-mails which is triggered from Tickets screen.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Service > Tickets.
- Open the desired Ticket.
- Perform the necessary steps to trigger the errors.
- Error messages below are shown:
- Please enter a party with role Sender.
- Please enter a party with role Employee Responsible.
- Save failed
Cause
For Tickets, the involved parties "Employee Responsible" and "Sender" are not available and cannot be added. However, for E-mail activity "Sender" and "Employee Responsible" are set as mandatory parties per default and cannot be changed. That is why these error messages can be triggered in Tickets screen.
Resolution
This is the system expected behavior.
If the feature/functionality is required urgently, please refer to KBA 3475641 - Functionality Currently not Available.
See Also
KBA: 3475641 - Functionality Currently not Available
Keywords
display, displays, displayed, show, shows, shown, happens, happen, occurs, occur, happened, occurred, appears, appear, appeared, visible, service request, email, e-mail, mail, activities, parties, party, fine-tuning, maintain determinations , KBA , LOD-CRM-SRP , Service Request Processing , LOD-LE-RC-PAP , Party Processing , LOD-CRM-SC-EML , Email , Problem
SAP Knowledge Base Article - Public