SAP Knowledge Base Article - Public

3689419 - Email address is not saved in "Email to" field under "Scheduling" tab in Integration Center

Symptom

When adding a new email address in the "Email To" field under the "Scheduling" tab in Integration Center, saving the changes, and then reopening the integration, the email address does not appear anymore, as if the changes were not saved.

Environment

  • SAP SuccessFactors HCM Suite
    • Integration Center

Reproducing the Issue

  1. Edit the integration job.
  2. Open the "Scheduling" tab.
  3. Provide an email in the "Email To" field and enable the "Email event logs for failed integrations" option.
  4. Click on the Save button.
  5. Close the integration, reopen it, and observe that the email is not there anymore.

Cause

Integration job already has a schedule, so the saving action alone does not take effect in the "Scheduling" tab.

Resolution

Along with saving the changes, you should also set a new schedule through "Set Schedule" button, otherwise changes in the "Scheduling" tab does not take effect.

In order to properly set a new schedule, make sure to set a new date in "Start Time" field.

Keywords

Email event logs for failed integrations, schedule, email to, integration centre, set schedule, business scenarios , KBA , LOD-SF-INT-INC-FWK , Integration Center UI Framework , Problem

Product

SAP SuccessFactors HCM Suite all versions