Symptom
Automatic benefit enrollment does not occur for employees who meet eligibility criteria in the rule trace
Environment
- SAP SuccessFactors Employee Central
- SAP SuccessFactors HCM Suite
Reproducing the Issue
- Configure a rule trace
- Navigate to Benefits Admin Overview
- Create a new "Evaluate Eligibility" job for an employee
- Review the rule trace and see that the user is considered eligible
- Check the job response and see that the user was considered ineligible
Cause
The rule configuration is using the 'Basic' scenario, which is less stable than specific scenario, or the rule is corrupted in the database.
Resolution
In order to solve the issue we recommend recreating the rule following the below steps:
- Recreate the eligibility rule using the specific scenario based in the benefit type - Creating a Scenario-Based Rule
- Configure the new rule in the benefit
After that the result in the rule trace and in the job should match.
See Also
Evaluating Eligibility Based on Benefit Master Data Change.
3377748 - Benefit not shown on open enrollment though Eligibility rule sets Entitlement Amount
Keywords
automatic benefit enrollment, eligibility criteria, SAP SuccessFactors Employee Central, global benefits, LOD-SF-EC-GBF, rule trace, evaluate eligibility job, rule corruption, scenario-based rule, benefit tracker, insurance plan benefit, eligibility rule failure, Evaluate rule for single user failed for user , KBA , LOD-SF-EC-GBF , Global Benefits , Problem
SAP Knowledge Base Article - Public