SAP Knowledge Base Article - Public

3689576 - Legacy people profile block displays nothing on HarmonyOS in SuccessFactors mobile APP

Symptom

  • Employee profile block displays nothing on HarmonyOS in SuccessFactors mobile APP
  • The issue occurs specifically on the HarmonyOS when accessing the legacy people profile

Environment

SuccessFactors Employee Central

Reproducing the Issue

  1. Switch to the legacy people profile.
  2. Login SuccessFactors APP using HarmonyOS on a mobile device.
  3. Navigate to any user's People Profile.
  4. Click on any block within the profile, the block displays nothing.

Cause

The issue occurs because the legacy people profile of SuccessFactors mobile version is rendered by internal browsers of mobile devices, and the HarmonyOS browser is not supported by SuccessFactors.

Confirm that the SuccessFactors mobile version only supports the following browsers:

  • Safari by Apple
  • Google Chrome for Android
  • Google Android default browser

The issue does not exist on the latest people profile, because the latest people profile no longer uses browser link as the basis of information display in most cases.

Resolution

It is recommended to use the latest people profile.

See Also

Refer to: Supported Mobile Browsers for SAP SuccessFactors | SAP Help Portal

Keywords

HarmonyOS, SAP SuccessFactors mobile version empty page, nothing is displayed on SuccessFactors mobile version, People Profile, PP3, PPX, personal information, employee profile block, browser compatibility, supported browsers, Safari, Google Chrome, Android default browser, Harmony browser issue, mobile app rendering issue, SAP SuccessFactors, could not access user information , KBA , LOD-SF-EP-FPP , People Profile - Full Profile , Problem

Product

SAP SuccessFactors Employee Central all versions