SAP Knowledge Base Article - Public

3689597 - DRTM Master Data Purge generated a purge result of "Completed with empty report"

Symptom

  • An issue occurs when attempting to purge users in SF Platform
  • Despite meeting the preconditions, some users cannot be purged.
  • Some users were not able to be purge even if "Ignore data retention time configuration for this purge request" is checked.

Environment

SAP SuccessFactors HCM suite

Reproducing the Issue

  1. Export the Affected Users
  2. Attempt to purge users in DRTM Master Data Purge.
  3. Ensure preconditions are met, including checking "Ignore data retention time configuration for this purge request."
  4. After launching the purge request, the request go directly to result skipping the approval.
  5. The purge result is "Completed with empty report".

Cause

The issue is caused by the absence of the "COUNTRY" key in the Table_USERS_INFO for specific users created via API during a prior defect.

Resolution

To resolve the problem, follow the steps below:

  1. Export affected users using Employee Export. Follow the KBA for guide: 2797141.
  2. Re-import the exported file using Basic Import to restore the missing "COUNTRY" key.
  3. Ensure "Process Inactive User" is checked during the import process.
  4. After completing the import, reattempt the purge process for the affected users.

See Also

Keywords

Employee Central, Purge failure, Missing country key, Table_USERS_INFO, API Import, Data Retention Management, DRTM, Process inactive user, Basic import, Employee Export, Purge , KBA , LOD-SF-PLT-DRM , Data Retention Management , Problem

Product

SAP SuccessFactors HCM Suite all versions