Symptom
- An issue occurs when attempting to purge users in SF Platform
- Despite meeting the preconditions, some users cannot be purged.
- Some users were not able to be purge even if "Ignore data retention time configuration for this purge request" is checked.
Environment
- SAP SuccessFactors Suite
Reproducing the Issue
- Attempt to purge users in DRTM Master Data Purge.
- Ensure preconditions are met, including checking "Ignore data retention time configuration for this purge request."
- After launching the purge request, the request go directly to result skipping the approval.
- The purge result is "Completed with empty report".
Cause
- The issue is caused by the absence of the "COUNTRY" key in the Table_USERS_INFO for specific users created via API during a prior defect.
Resolution
- Export affected users using Employee Export.
- Re-import the exported file using Basic Import to restore the missing "COUNTRY" key.
- Ensure "Process Inactive User" is checked during the import process.
- After completing the import, reattempt the purge process for the affected users.
Keywords
Employee Central, Purge failure, Missing country key, Table_USERS_INFO, API Import, Data Retention Management, DRTM, Process inactive user, Basic import, Employee Export, Purge , KBA , LOD-SF-PLT-DRM , Data Retention Management , Problem
Product
SAP SuccessFactors HCM Suite all versions
SAP Knowledge Base Article - Public