Symptom
- Mandatory error ccurs while submitting Higher Duty or Temporary Assignment, although the field is not visible when creating the assignment;
- The field is set to mandatory in BCUI;
- Error message displayed: "... is a required field and cannot be blank."
Environment
SAP SuccessFactors Employee Central
Reproducing the Issue
- Navigate to Employee Profile > Take Action;
- Select "Add: Higher Duty/Temporary Assignment;
- Fill the necessary fields;
- When submitting the assignment, an error is displayed: "... is a required field and cannot be blank."
Cause
Centralized services for Higher Duties have become universal post 2H 2025 release. All fields marked as mandatory in Manage Business Configuration must be populated, even if not visible in the UI.
Resolution
Set up a Business Rule to make the field non-mandatory specifically for Higher Duty scenarios using the Event Reason as an If Condition within the rule configuration.
Keywords
"XXX is a required field and cannot be blank." error when submitting Higher Duty/Temporary Assignment - 2H 2025, 2H 2025, ECT_service_layer_REQUIRED_FIELD_EMPTY, is a required field and cannot be blank, mandatory field error, job information, temporary internal assignment, higher duty, temporary assignment, centralized services, 2H2025 Release , KBA , LOD-SF-EC-HDP , Higher Duties & Public Sector , Known Error
SAP Knowledge Base Article - Public