SAP Knowledge Base Article - Public

3690696 - Error "Failed to process the job application" encountered by non-applicants after accepting online offer

Symptom

Non-applicants encounter the error message "Failed to process the Job application" after accepting an online offer and clicking on Next Action button.

Environment

SAP Successfactors Recruiting Management (RCM)

Reproducing the Issue

  1. Login to the career site using the candidate's email and password.
  2. Click on "Approve" and then "Next Step" to encounter the error message "Failed to process the Job application".

Cause

The candidate is currently a non-applicant, and while ATS supports generating an offer letter, the Multistage Application process requires the candidate to be an applicant—especially when the process includes a redirect to collect additional application data.

Resolution

Encounting the error "Failed to process the Job application" after accepting an online offer and clicking on Next Action is an expected behaviour and the offer status is updated right in RCM instance.

  1. Ensure that the candidate is configured as an applicant in the system before initiating the Multistage Application process.
  2. Refer to the documentation for enabling and configuring the Late-Stage Application process:

a href="https://help.sap.com/docs/successfactors-recruiting/setting-up-and-maintaining-sap-successfactors-recruiting/enabling-and-configuring-late-stage-applications" Enabling and Configuring Late-Stage Applications /a

See Also

a href="https://help.sap.com/docs/successfactors-recruiting/setting-up-and-maintaining-sap-successfactors-recruiting/enabling-and-configuring-late-stage-applications" Enabling and Configuring Late-Stage Applications /a

Keywords

failed to process the job application, non-applicant, online offer, next action, multistage application, late-stage application flow, offer letter, candidate offers , KBA , LOD-SF-RCM-CAO , Candidate Offers, Offer Letters , Problem

Product

SAP SuccessFactors Recruiting 2511