Symptom
A technical error occurs when creating the billing document.
Sorry, a technical error occurred. Please try again later.
{
"message": "HTTP request failed",
"headers": [],
"statusCode": 500,
"statusText": "",
"responseText": "500 Connection Timed Out\r\n\r\nTimeout occurred\r\nXXXX-YY-ZZ \r\n"
}
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Open the "Create billing documents" app.
- Select the delivery and create the invoice.
- Experience extended loading times, followed by a technical error.
Cause
This error often occurs with performance like long-time waiting. Possible reasons include:
- A large number of items in the billing document.
- Custom code that may take up much time.
Resolution
As a workaround, use the "Schedule billing creation" app to run a job for generating the invoice.
See Also
Help Portal - Schedule Billing Creation
Keywords
invoice creation, timeout error, HTTP request failed, processing timeout, billing document, delivery, order, processing, schedule billing creation, line items limit , KBA , SD-BIL-IV-2CL , Processing Billing Documents (Public Cloud) , Problem
SAP Knowledge Base Article - Public