SAP Knowledge Base Article - Public

3693312 - "User doesn't have the 'Employee Central HRIS OData API' permission" - OData

Symptom

While upserting data into Employee Central entities, the following error is returned by the API: User ****** doesn't have the 'Employee Central HRIS OData API' permission!".

Environment

  • SAP SuccessFactors Employee Central
  • OData API

Reproducing the Issue

  1. Prepare permissions as described in note 2316798.
  2. Execute the API requests to insert data into Employee Central entities.
  3. Observe the error message: "User ***** doesn't have the 'Employee Central HRIS OData API' permission!"

Cause

Upserts are only possible while having Admin permissions, such as the one that the error is requesting to be assigned. Regardless of all other permissions granted to the user, the permission 'Employee Central HRIS OData API' is required to make upserts

Resolution

Assign permission 'Employee Central HRIS OData API' to the user who is making the API requests.

Permissions for Employee Central Entities

See Also

Keywords

employee central hris odata api, permission error, api user permissions, odata api framework, employee central entities, empjob, data insertion error, admin permissions, required fields, api audit logs, import employee data tool, successfactors , KBA , LOD-SF-INT-EC , Employee Central SFAPI & OData Entities , LOD-SF-INT-ODATA , OData API Framework , Problem

Product

SAP SuccessFactors HCM Suite all versions