SAP Knowledge Base Article - Public

3693386 - Search icon is not visible when the option "Enable Global Search" is active.

Symptom

  • The visibility of the enterprise search icon is not correctly controlled by the option "Enable Global Search."
  • When the "Enable Global Search" option is enabled, the enterprise search icon is not visible.
  • If the "Enable Global Search" option is disabled, the enterprise search icon becomes visible.

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Navigate to Company Settings.
  2. Enable the "Enable Global Search" option.
  3. Observe that the global search bar is not visible.
  4. Disable the "Enable Global Search" option.
  5. Observe that the global search bar becomes visible.

Cause

The C4C system offers two types of search features.

  1. Global Search | SAP Help Portal
  2. Enterprise Search | SAP Help Portal

The search bar displayed in the top middle of the page is the Global Search.

The search icon displayed in the top right corner is the Enterprise Search.

Using both options, "Enable Global Search" and "Disable Enterprise Search," simultaneously will cause the inconsistency detailed in the symptom section.

Resolution

If you want to use Global Search, please ensure the Agent Desktop is activated in your C4C tenant. Otherwise, please disable the "Enable Global Search" option and use "Disable Enterprise Search" to control the visibility of the search icon(Enterprise Search)

See Also

Keywords

global search, enable global search, search bar visibility, company settings, search functionality , KBA , AP-RC-UIF , C4C UI Framework , Problem

Product

SAP Cloud for Customer core applications all versions