Symptom
- After a recent Integration Center configuration update, the background check integration begins executing repeatedly and continuously.
- Repeated submissions of the old candidate/application data to the background check vendor, causing duplicate requests.
- Vendor reports of receiving thousands of records.
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
- Open Integration Center > Monitor Integrations and locate the background check integration.
- Notice that it is executing repeatedly.
Cause
The integration center job has been manually executed by clicking 'Run Now'.
Resolution
Do not manually run the background check integration during configuration update. Clicking the Save button is sufficient to save changes.
Troubleshooting steps:
- Navigate to 'Scheduled Jobs Monitor'.
- Select 'Job Type: Integration Center' and Click 'Go'. This will retrieve scheduled and manually executed integrations.
- Locate the background check integration.
- Check the 'Progress' status.
- Click on the job name to view details.
- Check the 'Occurrence', which will display 'One-Time' if the job was manually executed.
If the status is still "In Progress", terminate the job from Provisioning:
- Navigate to Provisioning > Monitor Jobs
- Select 'Job Type: Integration Center' and click 'Refresh'.
- Locate the background check integration.
- Click the Terminate option next to the job to stop it.
Keywords
RCM, Background Check, Integration, Center, Candidate, Application, duplicate, Numerous, Repeated, vendor, third party , KBA , LOD-SF-RCM-BCI , Background Check , Problem
Product
SAP SuccessFactors Recruiting all versions
SAP Knowledge Base Article - Public