Symptom
- All positions are no longer visible in the History UI for Job Information. Previously, all positions were displayed regardless of the "To Be Hired" status.
- When users attempt to enter a position number, the system returns "No Data."
- Same issue is not seen when using the Legacy People Profile
Environment
SAP SuccessFactors Employee Profile
Reproducing the Issue
- Navigate to the user's profile.
- Click Job Data, select History, then select Correct.
- Copy position value.
- Delete value in the field.
- Paste position code to the field.
- Receive "No Data" message.
Cause
The issue occurs due to the "Allow Selection of only Positions that have Status 'To Be Hired' in Manager Self-Service Job Information, Hire, and Quick Actions" setting being applied to the History UI, which is unintended behavior.
Resolution
- SAP Engineering team are investigating this issue.
- Please follow and bookmark this KBA for further developments.
Workaround:
Navigate to Position Management settings > UI Customizing.
- Set the feature "Allow Selection of only Positions that have Status 'To Be Hired' in Manager Self-Service Job Information, Hire, and Quick Actions" to No.
- This adjustment will allow positions with both "To Be Hired" statuses (Yes and No) to be visible in the History UI, Manager Self-Service, hire, and related areas.
See Also
Keywords
positions not visible, history UI, job information, to be hired status, no data error, SAP SuccessFactors, position management settings, dropdown issue, manager self-service, employee central, KI2H2025 , KBA , LOD-SF-EP-FPP , People Profile - Full Profile , Bug Filed
Product
SAP SuccessFactors Employee Central all versions
SAP Knowledge Base Article - Public