SAP Knowledge Base Article - Public

3694129 - EP email address got removed

Symptom

For some EC users, their corresponding email info saved in EP "Email" standard element(For EC users) get wiped out after HRIS sync. Especially, customer is seeing the numbers of such users get increased daily.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Employee Central

Cause

https://jira.tools.sap/browse/PTCH-48523

We had multiple customers who reported that when there is no Business email address maintained , the data was not updated to EP side which turned out to be a legacy code defect. The code fix delivered on Dec 4th was implemented to address the data inconsistency issue between EC emailInfo and standard element Email — an essential step to align with our product’s core design requirement of ensuring reliable data synchronization between EC and EP.

After the code fix, to maintain data consistency, HRIS sync will set the Email field in UDF to blank for employees who have no business email maintained in their Contact info. Additionally, if a customer has a daily scheduled HRIS sync job and a user has had changes on the EC side since the last successful HRIS sync, the user’s emailInfo (corrected from the original typo "emailInof") will be synced to EP, and if there is no Email address in EC, his email in UDF will the wipe off. The numbers of affected user will be increasing.

In summary, this is expected. 

Resolution

For EC enabled customers, Employee Central is the core system that manages employee information throughout their lifecycle in an organization. Therefore, HRIS sync is the key process to ensure the data consistency between Employee Central and EP. HRIS sync synchronizes some Employee Central data based on the hard-coded sync mappings from HRIS fields to standard and userinfo elements. “emailinfo” is one of the fields:

For all EC Customers, it is recommended to import the Email Information to Contact Information 

Admin Center -> Import Employee Data -> Email Information with the right “email-type” .

Fields Hard-Coded for Syncing | SAP Help Portal 

For an employee, only business email will be synced to EP. 2507071 - Employee Central - Email Info HRIS  

Best Recommended Solution:

Given the HRIS sync best practice, we recommend customer maintaining all Employee Data in EC system and using hard-coded HRIS sync logic or customized HRIS SYNC Mappings:Helpl Portal | Custom HRIS Sync Mappings  to sync data to EP

For all EC Customers, it is recommended to import the Email Information to Contact Information 

Admin Center -> Import Employee Data -> Email Information with the right “email-type” .

Run a Full HRIS sync job to sync data to UDF, EC Users Business Email will be synced to UDF as expected.

HRIS Sync will take care of updating data automatically to UDF for new comers.

Possible Workaround:

If in other cases, customer has special requirements for maintaining different types of Email Info in UDF for different EC users, there is workaround available, Please help to contact Engineering team for further support.

See Also

2080065 - What is a Full HRIS Sync? - Employee Central - SAP for Me 

2507071 - Employee Central - Email Info HRIS  

Help Portal| Fields Hard-Coded for Syncing 

Keywords

INC17992834, ECT-265267, New PTCH-48900,  old PTCH-48523, email address disappeared, email address removed, EP email address removed, EP email address deleted employee profile, employee central, full hris sync, delta hris sync, daily HRIS sync, EC and EP data inconsistency , KBA , LOD-SF-EC-HRS , HRIS Sync , How To

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Core 2511