SAP Knowledge Base Article - Public

3694310 - Checking Odata Get Calls There Is A Duplicate Field

Symptom

Checking Odata get call at Postman, there will be a specific field appearing multiple times. Nevertheless, the same URL used in C4C Odata console doesn't bring duplicates fields, is also not happening for regular browser. 

Environment

SAP Cloud for Customer 

Reproducing the Issue

  1. Login to the affected tenant.
  2. Execute GET in Odata call, e.g.: https://my0000000.crm.ondemand.com/sap/c4c/odata/v1/c4codataapi/TasksCollection?$filter=ID eq '11111'
  3. Search for the affected custom field and notice that it is duplicated. 

Cause

The PDI fields added to standard OData services(XODATA) gets the field name suffixed with "_SDK".

In this case, ideally the property should have been added like "1234_SDK", but it is added without the pre-fix "_SDK".

Resolution

Possible solution: 

  • Rename the PDI field.   
  • Remove and add the PDI field to the OData service via XOData editor (lunched from PDI).
  • Customer needs to adopt the change.

Keywords

Odata; get; call; postman; field; appearing; multiple; times; duplicated; URL; console; browser.  , KBA , AP-RC-BDS-EXT , ByDesign Studio Extensibility , LOD-CRM-INT-API , OData API (C4C Only) , How To

Product

SAP Cloud for Customer core applications 2508