SAP Knowledge Base Article - Public

3694841 - "Completed By" Field Appears Blank in Custom Onboarding Tasks – Onboarding

Symptom

  • The "Completed by" field remains blank despite the task being completed.
  • The affected user is part of the ONB dynamic group but cannot view their own name in the "Completed by" field.
  • Other users in the same permission group can view their names in the "Completed by" field.

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  1. Assign the affected user to the correct permission role.
  2. Ensure the permission role has the option enabled: "Exclude granted users from having the same access to themselves."
  3. Attempt to complete a task and verify the "Completed by" field.

Cause

  • The issue arises due to the 'employee export' permission assigned to the affected user within the assigned permission role.
  • The permission role has the option enabled: "Exclude granted users from having the same access to themselves."

Resolution

  1. Disable the option "Exclude granted users from having the same access to themselves" in the assignments of the permission role.
  2. Alternatively, remove the 'employee export' permission from permission role.

See Also

Keywords

completed, by, field, blank, onboarding, custom, tasks, ONB, dynamic, group, permission, role, employee export, exclude granted users, task, completion, visibility, permissions, user, access, settings , KBA , LOD-SF-OBX-NHA , New Hire Activities (activities, tasks, buddy, equipment) , Problem

Product

SAP SuccessFactors Onboarding all versions