SAP Knowledge Base Article - Public

3695104 - Error message "Input Benefits are empty" occurs when enrolling users into benefits after creating an exception post open enrollment

Symptom

An error occurs when attempting to enroll users into benefits after creating exceptions post Open Enrollment. The error message displayed is "Input Benefits are empty". 

This error occurs only in the scenario wherein the Open Enrollment window (Effective start date in future) is over and an exception is created to allow the users to complete the open enrollment, and the benefit has a future-dated time slice. 

Environment

SAP SuccessFactors Employee Central - Global Benefits

Reproducing the Issue

  1. Navigate to the affected user and click on the Benefits card.
  2. Proceed to the Open Enrollment under Benefit Actions.
  3. Observe the error message "Input Benefits are empty" displayed in the Benefits Open Enrollment screen.

Cause

This issue is occurring due to a code defect.

Resolution

Engineering team has fixed this issue via a code correction (BEN-21150) in the 1H 2026 release.

Until then, please follow the below steps as a workaround to resolve the error:

  1. For the impacted benefits, update the benefit time slice start date to the current date (via Benefits Admin Overview screen). 
  2. Allow employees to complete open enrollment.
  3. After employees complete the open enrollment, modify the benefit time slice date back to the future-dated time slice. 

Keywords

CS20250011109284, INC16960867, BEN-21150, SAP SuccessFactors, Employee Central, error, input benefits are empty, open enrollment, exception, benefit, time slice, future, start date, enrollment error , KBA , LOD-SF-EC-GBF , Global Benefits , Known Error

Product

SAP SuccessFactors Employee Central 2511