Symptom
- There seems to be inconsistency in the DateTime value returned in the Get Quote API call.
- The difference in the time returned is causing a change in the date when an external system consumes the data retrieved by Get Quote API.
Environment
SAP CPQ
Reproducing the Issue
- Go To Quotes
- Fill in the start date on start contract date in custom field
- Use get item api/v1/quotes/items run
- GetQuote APi through Postman to check value of ContractStartDateNew
Cause
The issue is caused by discrepancies in date and time representation due to the use of different time zones. The API is configured to use UTC format instead of aligning with the user's local timezones.
Resolution
- Ensure that the parameter Market Time Zone is set to TRUE.
- Navigate to Setup -> General -> Application Parameters -> Shopping Cart and Quotes tab -> Use Market Time Zone.
- Once enabled, the date fields (both standard and quote item custom fields) will automatically adjust to the market time zone.. All date fields are saved with the time component set to 0 (midnight).
- The API provides date fields in ISO8601 format, ensuring that converting the value from the CPQ response to the market time zone will match the date displayed in CPQ, with the time component remaining at 0.
See Also
Keywords
API, Datetime value, Quote, Custom field , Contract end date, CPQ , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , How To
Product
SAP CPQ all versions
SAP Knowledge Base Article - Public