Symptom
EDI integration processing fails with an error "Business partner cannot be uniquely determined by GLN XXX".
Environment
SAP S/4HANA Cloud Public Edition
Cause
GLN (Global Location Number) is not maintained under the respective Business Partner, because of which system is unable to uniquely determine the correct Business Partner during inbound processing and therefore raises the error.
Resolution
Follow the steps to resolve the issue:
- Open the respective Business partner associated with the EDI
- Open 'Identification' tab under BP role FLCU01 (Customer)
- Maintain the GLN number XXX under fields 'Int.location no. 1' and 'Int. location no. 2' and retest.
Keywords
GLN, Business partner cannot be uniquely determined by GLN XXX, EDI, edi integration, Int.location no. 1, Int. location no. 2 , KBA , SD-SLS-EDI-2CL , S/4HANA: Sales EDI Messages (Public Cloud) , SD-SLS-EDI , S/4HANA: Sales EDI Messages , Problem
SAP Knowledge Base Article - Public