Symptom
- Manager field in the User entity is not updated via Integration Center Job.
- The integration center job query preview displays the correct manager value, but after execution, the User employee profile retains the old manager value.
Environment
- SAP SuccessFactors Integration
- Integration Center Job
Reproducing the Issue
- Login to the instance with given support access.
- Navigate to the integration center.
- Edit the integration.
- Preview the payload to verify the details of fields that are getting updated.
- Check the current Manager value of the user in the User employee profile.
- Run the integration center job.
- Observe that the Manager value is not updated in the User employee profile.
Cause
This is a known issue.
Resolution
- Add an additional dummy value mapping under the Manager navigation.
- Note that this workaround will result in two records—one for the User entity and another for the Manager record.
- The issue has been identified as a code defect and will be addressed in the upcoming release(1H2026).
Keywords
manager field, integration center job, user entity, Sap SuccessFactors Platform, manager value not updating, integration issue, code defect, workaround, dummy value mapping, upcoming release, Integration center job , KBA , LOD-SF-INT-INC-JOB , Integration Center Job , Known Error
Product
SAP SuccessFactors Platform all versions
SAP Knowledge Base Article - Public