Symptom
Purpose of the two Checkboxes in the Outlook Add-In Field Settings (Enable Field vs. Display on Create)
Environment
SAP Cloud for Customer
Reproducing the Issue
- Access the Outlook Add-In settings.
- Locate the field options: "Display on create" and the general enablement field on the left of the field name.
- Attempt to configure these options while observing their effects on the field visibility and functionality in the Outlook Add-In.
Cause
- The general enablement field on the left of the field name activates the field for the Outlook Add-In. If this field is not selected, the field will not appear in the add-in under any scenario.
- The "Display on create" option controls whether the field is displayed when creating a new object from the Outlook Add-In but does not enable the field independently.
Resolution
Enable the field using the checkbox on the left side of the field name to make it available for the Outlook Add-In. Then use “Display on create” to control whether the field should be shown during object creation.
See Also
- Refer to SAP Help Portal: SAP Cloud for Customer Add-In for Microsoft Outlook
- Refer to SAP Help Portal: Manage Contacts
- Refer to SAP Help Portal: Solution Guide for SAP Service Cloud
Keywords
SAP Cloud for Customer; C4C; NGAP; V1; Outlook Add-In; Email Integration; Field Configuration; UI Adaptation; Display on Create; Field Enablement; Checkbox Behavior; System Behavior; By Design; Object Creation; Visibility Settings; Integration Settings; Add-In Configuration; Standard Functionality; User Interface; Configuration , KBA , LOD-CRM-GW-OUT , Outlook , How To
SAP Knowledge Base Article - Public