SAP Knowledge Base Article - Public

3695935 - Difference Between Field Enablement and Display on Create in the Outlook Add-In

Symptom

Purpose of the two Checkboxes in the Outlook Add-In Field Settings (Enable Field vs. Display on Create)

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Access the Outlook Add-In settings.
  2. Locate the field options: "Display on create" and the general enablement field on the left of the field name.
  3. Attempt to configure these options while observing their effects on the field visibility and functionality in the Outlook Add-In.

Cause

  • The general enablement field on the left of the field name activates the field for the Outlook Add-In. If this field is not selected, the field will not appear in the add-in under any scenario.
  • The "Display on create" option controls whether the field is displayed when creating a new object from the Outlook Add-In but does not enable the field independently.

Resolution

Enable the field using the checkbox on the left side of the field name to make it available for the Outlook Add-In. Then use “Display on create” to control whether the field should be shown during object creation.

See Also

Keywords

SAP Cloud for Customer; C4C; NGAP; V1; Outlook Add-In; Email Integration; Field Configuration; UI Adaptation; Display on Create; Field Enablement; Checkbox Behavior; System Behavior; By Design; Object Creation; Visibility Settings; Integration Settings; Add-In Configuration; Standard Functionality; User Interface; Configuration , KBA , LOD-CRM-GW-OUT , Outlook , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions