Symptom
Scheduled Invoice Request XYZ is in status With Conflict with the following warnings (XYZ represents the Scheduled Invoice Request ID):
Conflict in item YY; the referenced invoice schedule data was changed (YY represents the line item number of the Scheduled Invoice Request)
Conflict in item XX; invoice schedule item XX: date has changed (XX represents the line item number of the referenced Contract line item number)
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Customer Invoicing work center.
- Select the Invoice Requests view.
- Select Scheduled Invoice Request XYZ.
The status is With Conflict and the Line Item YY which is referenced to Contract ABC Line Item XX has the status Conflict (ABC represents the Contract the Scheduled Invoice Request is based on). - Click on the Check button.
- In the new window the the following warnings are displayed:
Conflict in item YY; the referenced invoice schedule data was changed
Conflict in item XX; invoice schedule item XX: date has changed
Cause
The Scheduled Invoice Request XYZ was invoiced with Customer Invoice EFG but the Invoice was not Released (EFG represents the invoice ID).
After the Invoice was created, a change of the Invoice Schedule Date, for which the Scheduled Invoice Request XYZ was created, in the Invoice Schedule of the Contract ABC for Line Item XX was performed.
This caused the update to the Scheduled Invoice Request XYZ which at this point was already invoiced but since the Invoice was not released the change was still possible.
This is why the item is with conflict and the warnings are displayed when clicking on the Check button.
In an example:
The Invoice Schedule Date of the Contract Item was 01.12.2025
The Scheduled Invoice Request was created for the Invoice Date of the 01.12.2025 for the Item.
The Scheduled Invoice Request was invoiced but the Invoice was not released.
Then the Invoice Schedule Date was changed from 01.12.2025 to 12.12.2025 in the Contract for the Item.
This changes the status of the Scheduled Invoice Request to With Conflict since the Scheduled Invoice Request was created and invoiced with a different Invoice Schedule Date that there is now maintained in the Contract.
Resolution
This is the expected System behavior.
To solve the issue the customer needs to cancel Customer Invoice EFG.
The Status of Scheduled Invoice Request XYZ will then change to Processed and the Line Item YY with the reference to Contract ABC line item XX will then change to Canceled.
You then need to trigger a new Scheduled Invoice Request for the changed Invoice Schedule Date using the following steps:
- Go to the Customer Invoicing work center.
- Select the Invoice Requests view.
- Select Customer Contract Invoice Request ABC.
- Click on the Edit button.
- Click on the You Can Also button and select Create Scheduled Invoice Request.
- Click on Save.
- Click on Close.
A new Scheduled Invoice Request with the changed Scheduled Invoice Date will be created in Status To Be Invoiced and you can then invoice it.
See Also
Keywords
invoice request conflict, customer invoicing, status conflict, Scheduled Invoice Date, with conflict, Conflict in item, invoice schedule item, date has changed, the referenced invoice schedule data was changed. , KBA , SRD-CRM-INV , Customer Invoicing , AP-CCP-CC , Customer Contract , AP-CI-CI , Customer Invoice , Problem
SAP Knowledge Base Article - Public