Symptom
When creating a Service/Solution order and selecting an user as the service executer (which is assigned to multiple work agreements) the cost center of the service document is automatically being assigned.
Environment
SAP S/4HANA Cloud Public Edition
Cause
When an worker is creating a Service/Solution Order and they have multiple work agreements, the Cost Center of the Service document will be defaulted to the cost center that is selected the first work agreement.
The system follows the determination logic below:
- After adding a Service or Expense item into a Service/Solution order, the system assigns an "Executing Service Employee" (Partner Function).
- The system reads the specific Work Agreement linked to that Executing Service Employee.
- It then pulls the Cost Center defined for that agreement in the "Manage Workforce" app.
Resolution
Since the Cost Center is defined in the Work Agreement, it is possible to change the cost center of the Service/Solution order by either:
- Changing the Cost Center in the primary work agreement from the executing service employee selected in the document.
- Changing the executing service employee to one that has the desired cost center.
See Also
Keywords
work, agreements, CO, manage, workforce, cost, center, service, order, solution, primary, document, behavior, multiple, service, employee, executor, , KBA , CRM-S4-SRV-SVO-2CL , S4CRM: Service Order (Public Cloud) , Problem
SAP Knowledge Base Article - Public