Symptom
Error "unable to nudge assignee(s) for this activity" when clicking nudge button in "Personal Data Collection" step.
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Search for a candidate from the onboarding dashboard.
- Identify that the "Personal Data Collection" task is not yet completed.
- Attempt to click the Nudge button behind "Personal Data Collection"
- Observe that the error message "Unable to nudge assignee(s) for this activity." is displayed. But once completed, it can be nudge successfully.
Cause
Missing user email due to HRIS Sync Mapping configuration.
Resolution
This behavior may occur when an affected onboardee does not have an email address maintained in the system.
In some cases, this can be caused by HRIS Sync Mapping configuration, where the User Email field is mapped to a field like (custom-stringxx) from an HRIS entity. When such mapping is configured, the value from the mapped field is synchronized to the user email.
If the mapped field does not contain a value, the user email remains empty, which may prevent the Nudge functionality from working and result in the error.
To resolve the issue:
-
Navigate to Manage Business Configuration -> HRIS Sync Mapping.
-
Identify whether the User Email field is mapped to any HRIS entity field.
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Verify that the mapped field contains a valid email value.
If the mapped field is empty:
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Maintain a valid value in the mapped field, or
-
Remove or adjust the HRIS Sync Mapping if it is not required.
See Also
- SAP SuccessFactors Product Release & Road Map Information
- SAP SuccessFactors Patches Knowledge Base
- KB Article 2171560 - How to be notified of new or updated SAP Notes or KBAs
Keywords
SAP Knowledge Base Article - Public