SAP Knowledge Base Article - Public

3696721 - Referred candidates are not redirected to the job posting after account validation - Recruiting Management

Symptom

  • Customer Data Cloud is enabled
  • New candidates who are referred cannot access the job posting screen after resetting their password.
  • Candidates are redirected to the candidate profile instead of the job posting screen.

Environment

SAP SuccessFactors Recruiting Management

Reproducing the Issue

  1. An internal user refers a friend for a job.
  2. An email is sent to the referred person containing a referral link.
  3. The referred person opens the URL in the email.
  4. The referred person sets a new password.
  5. The referred person logs in using their email address and newly set password.
  6. The referred person accepts the data privacy statement.
  7. The referred person is redirected to their candidate profile instead of the job posting screen.

Cause

Expected behavior with CDC enabled

Resolution

Our Product Management team stated that this the expected behavior with CDC enabled.
However, there is an Enhancement ongoing to address this situation but there is no defined timeline yet.

Please note that candidates are still able to log in and apply for jobs as expected.  

You can bookmark this article to get update or reach out to your CSP to get update on the ongoing task.

See Also

Keywords

candidate referral issue, job posting screen, password reset, sap successfactors recruiting, candidate data cloud, referral link redirection, two-factor authentication, RMK site home page, candidate profile redirection, RCM-157559, CDC , KBA , LOD-SF-RCM-CAN , General Candidate Issues (not Offers, not Profiles) , LOD-SF-RCM-CAN-CDC , Customer Data Cloud Authentication , Product Enhancement

Product

SAP SuccessFactors Recruiting all versions