SAP Knowledge Base Article - Public

3697036 - I9 Reverification Launched but Citizenship Status changed - Onboarding

Symptom

In a I9 Reverification step document selection has no option to select candidate citizenship document.

Environment

SAP SUCCESSFACTORS ONBOARDING

Cause

This is an existing gap in document selection drop down list of item.

Resolution

Engineering is working to provide a permanent fix for this. Mean time, customer can follow below workaround:

  1. Navigate to Manage Data and locate the I-9 User Data for the affected candidate.
  2. Update the citizenship status to Citizen of US.
  3. Once updated, the manager will be able to select the appropriate document (e.g., US passport) for US citizens and complete Section 3.
  4. Sign the document, and the PDF will reflect the selected document accurately.

Keywords

OBX, I9 Reverification, Citizenship, Citizen, US Passport, I-9 Reverification, I9 Section 3 , KBA , LOD-SF-OBX-I9 , i9 Compliance Form , Product Enhancement

Product

SAP SuccessFactors Onboarding all versions