Symptom
- Advance Analytics Time Period Custom is showing results a day before the selected date range.
- When selecting a custom date range, such as 01/10/2025 to 31/10/2025, the system displays results for 30/09/2025 to 30/10/2025.
- The issue occurs consistently across all selected time ranges.
Environment
SuccessFactors Recruiting Marketing
Reproducing the Issue
- Access Recruiting.
- Navigate to Advance Analytics.
- Select the Time Period option and set it to Custom.
- Choose a sample date range, e.g., September 1st – 30th.
- Observe that the displayed results are shifted by one day earlier than the selected range.
Cause
When a user performs a date-based query, the application converts the datetime value to UTC+0 before converting it back to the user’s local timezone. The conversion to user local timezone is somehow not happening which caused the displayed dates to be one head of selected date.
Resolution
The issue is now being investigate by Engineering team.
Click on the star icon to follow and mark the KBA as one of your favorites to get notified of any updates.
Keywords
advance analytics, custom time period, filter issue, date range discrepancy, UTC+0, UTC+1, time zone conversion, incorrect date display, recruiting analytics, advanced analytics, professional services, INC16941354 , KBA , LOD-SF-RMK-AAN , Advanced Analytics - Professional Services , Bug Filed
SAP Knowledge Base Article - Public