SAP Knowledge Base Article - Public

3697196 - Error when generating 360 detailed report

Symptom

Encountered below error when clicking open the 360 detailed report on a 360 form:
 [OData Service form360GetDetailedReportInfo Failed, Error Status: error, errorThrown: Internal Server Error Error Message: Cannot invoke "com.successfactors.cotalentfoundation.service.forms.meta.form360Review.COForm360DetailedReportRaterCategory.getRaters()" because the return value of "java.util.Map.get(Object)" is null].

Environment

SAP SuccessFactors 360 Reviews

Reproducing the Issue

  1. Launch the 360 Review form for the employee.
  2. Upload the participant list CSV file, including a category that is not configured in the 360 form template.
  3. Participants complete the form.
  4. Click open the 360 Detailed Report on form.
  5. Receive error message: [OData Service form360GetDetailedReportInfo Failed, Error Status: error, errorThrown: Internal Server Error Error Message: Cannot invoke "com.successfactors.cotalentfoundation.service.forms.meta.form360Review.COForm360DetailedReportRaterCategory.getRaters()" because the return value of "java.util.Map.get(Object)" is null].

Cause

There are participants with invalid category (category which is not configured in the 360 form template).

Resolution

Use the "Change Participant Category" tool to change the invalid category for the affected participant.

See Also

Changing Participant Category

Keywords

OData service error, 360 detailed report, category, missing category, invalid category, change participant category, upload participant, list, report generation failure, form360GetDetailedReportInfo, COForm360DetailedReportRaterCategory.getRaters, java.util.Map.get(Object) , KBA , LOD-SF-MTR-REP , Reporting & Analytics, Data Imports & Exports , Problem

Product

SAP SuccessFactors Performance & Goals all versions