SAP Knowledge Base Article - Public

3697656 - Duplicated address records in employee profile after being created by simultaneous OData API Upserts

Symptom

When Upserting data into PerAddressDEFLT, the records are getting duplicated in the employee's profile.

This issue only happens if you are sending two separate Upsert calls to create these records, with them being sent almost simultaneously (within the same second).

Environment

  • SAP SuccessFactors HCM Suite
    • OData API

Reproducing the Issue

  1. Run the OData API upserts, with both requests being sent simultaneously (within the same second).
  2. Observe the duplication of the address records in the employee's profile in the UI and reports.

    Cause

    There is a limitation in the OData API when handling simultaneous requests with payloads containing address information for the same employee, which results in the duplication of records.

    Resolution

    The SucessFactors Engineering team is already aware of this limitation and they plan to work on it in the future. There is no ETA at the moment for a permanent fix.

    You can avoid this issue by combining the payload of the two Upsert calls into a single Upsert call. This will ensure that such issue does not happen.

    Keywords

    duplicate, duplicated, address records, addressType, OData API, duplication, , KBA , LOD-SF-INT-EC , Employee Central SFAPI & OData Entities , Problem

    Product

    SAP SuccessFactors HCM Suite all versions