Symptom
The following error status is displayed in the Message Monitor (or Message Dashboard): Unknown host name (ICM_HTTP_HOST_UNKNOWN) error is also seen in the application log.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
-
Create a document (for example, RFQ or PO).
-
Publish the document.
-
Navigate to the Message Dashboard or Message Monitor.
-
Select the relevant integration interface.
-
Observe the failed message with the error ICM_HTTP_HOST_UNKNOWN in the error log.
Cause
The Service URL maintained in the corresponding Communication Arrangement is incorrect or invalid. The system is unable to resolve the target hostname via DNS.
Resolution
1. Communication System
-
Host Name: Must match the valid SAP Ariba CIG endpoint.
2. Communication Arrangement
-
Outbound Services settings must be:
-
Service Status: Active
-
Port: 443
-
Path: /cxf/receiveS4SOAP
-
Keywords
RFQ, Ariba, ICM_HTTP_HOST_UNKNOWN, Message Monitor, DNS, Service URL, Communication Arrangement, Communication System, CIG, receiveS4SOAP,42K,4BL,2NV , KBA , MM-PUR-HUB-RFQ-2CL , Central RFQ/Central Quotations (Public Cloud) , Problem
SAP Knowledge Base Article - Public