Symptom
Email notification is not triggered when a new employee is created (hired) using Workflow Rules in SAP Business ByDesign.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to Application and User Management work center.
- Navigate to Workflow Rules and create a new rule.
- Set Timing as On Create Only and Rule Type as E Mail.
- Save and activate the rule.
- Create a new employee from Personnel Administration.
- Observe that no email notification is triggered.
Cause
This is standard system behavior, as workflow rules do not support triggering notifications on employee creation (hiring). For the Employee business object, workflow rules are supported only for change, transfer, and termination.
Resolution
This is a current system limitation. For enhancement requests, please submit a proposal via SAP Influence Portal: https://influence.sap.com/sap/ino/.
As a workaround, the following approach can be used to receive notifications for newly created employees:
Notifications can be received by subscribing to system-generated Business Tasks created during employee hiring. When a new employee is created, the system automatically generates tasks to complete payroll and compensation data.
Steps to Subscribe:
- Go to Home and open Inbox.
- Click Subscribe to Task.
- Expand Personnel Administration and then Regular Task.
- Select the E mail checkbox for the task Complete Payroll Data – Country (Hire) for Employee Name (Employee ID).
Or
- Expand Compensation and then Employee.
- Select the E mail checkbox for the task Complete Compensation Data (Hire) for Employee Name (Employee ID).
See Also
Keywords
workflow rule, email notification, employee creation, sap business, workflow rules view, application and user management, trigger notification, employee hiring, define actions, rule type email, new employee creation , KBA , SRD-CC-BTM , Business Task Management , Problem
SAP Knowledge Base Article - Public