SAP Knowledge Base Article - Public

3698106 - S/4HANA CDS Views not visible in SAC

Symptom

When trying to use a CDS View in SAC, not all of the views are showing.  Some are visible and some are not.

Environment

  • SAP Analytics Cloud
  • SAP S/4HANA

Cause

S/4 is uses the Discovery Service to find all OData Services as well as the Entities under them. The Discovery Service Gateway will only return Services with Entities if the Entities have previously been cached. If a Service did not have the Entities cached, then it would return as if it did not have any Entities. SAC will filter out Services that don't have Entities and as a result, it may appear like certain Services are missing. 

Resolution

If there are CDS views that exist, but can't be seen/selected in SAC, then please run the $metadata service directly from a browser, using below URL format.
http://<S4HANA_SERVER>:<PORT>/sap/opu/odata/sap/<SERVICE_NAME>/$metadata

Running the metadata of the missing services may help them to appear in SAC.

Keywords

S/4HANA CDS Missing SAC Cache , KBA , LOD-ANA-AQU-ODATA , Acquiring Data into SAC using an ODATA connection , Problem

Product

SAP S/4HANA Cloud Public Edition 2508