Symptom
The HANA table analysis application in the production environment does not display any data.
Environment
- Technical Monitoring (Cloud version)
- SAP Business Technology Platform (SAP BTP).
Reproducing the Issue
- Open the HANA table analysis application.
- Observe that no data is displayed.
Cause
The HANA table analysis application provides information exclusively about customer-owned HANA tables.
If the user does not have the necessary authorization to view those tables, no data will be displayed.
Resolution
- Verify whether the user has the required authorization to view customer-owned HANA tables.
- Ensure that the tables are created in the customer namespace (e.g., tables starting with "Z").
- If the user lacks authorization, update the user's permissions to include access to the relevant customer-owned tables.
See Also
Keywords
Hana table analysis, no data displayed, customer-owned tables, authorization, technical monitoring, Z tables, User permissions, BTP , KBA , BC-OP-MON , ABAP Technical Monitoring an Observability , Problem
Product
SAP S/4HANA Cloud 1711 ; SAP S/4HANA Cloud 1802 ; SAP S/4HANA Cloud 1808
SAP Knowledge Base Article - Public