Symptom
Error message: "FM call to save Mail Body failed" appears when attempting to save changes made to the design facet of an uploaded newsletter document.
Environment
SAP Cloud For Customer
Reproducing the Issue
- Navigate to the Sales Campaign Work Center.
- Access the Content Work Center View.
- Create a new email template.
- Go to the Details section.
- Add the language and upload the file.
- Proceed to the Design facet.
- Click "Edit" on the left side of the uploaded document.
- Add or type content into the document.
- Return to the uploaded document on the left side in the Design facet.
- Click "Done".
- The error message "FM call to save MailBody failed" is displayed.
Cause
- Browser cache or history may affect the functionality.
- Browser may not support certain languages.
- Issue with the newsletter file itself.
Resolution
- Attempt to replicate the issue using a different browser.
- Use Google Chrome with the latest update as it is generally compatible.
- If the issue persists, raise a case with SAP for further investigation.
See Also
Keywords
newsletter design, FM call to save MailBody failed, email template error, campaigns, placeholder issue, browser compatibility, Google Chrome, save error, design facet, uploaded document error, SAP Cloud for Customer , KBA , LOD-CRM-MKT-CAM , Campaigns , LOD-CRM-MKT-CNT , Marketing Content Editor , Problem
Product
SAP Cloud for Customer core applications all versions
SAP Knowledge Base Article - Public