Symptom
"Set Posting Periods" button becomes disabled (greyed out) in app Manage Posting Periods. How to maintain the restriction?
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Environment
SAP S/4HANA Cloud Public Edition
Cause
The root cause should be that the following `Restriction Types` are currently set to `Restricted` in the `Access category` Write, and no values have been maintained for them.
- Access Category: Write
- Access Restriction: Restricted
- Restricted Field: Posting Period Variant
- Restriction types:
Manage Posting Periods: Authorization Groups
Manage Posting Periods: Period Variants
Manage Posting Periods: Periods
Resolution
Update the following restriction types within the `Access Category` to `Unrestricted`or maintain values accordingly:
- Manage Posting Periods: Authorization Groups
- Manage Posting Periods: Period Variants
- Manage Posting Periods: Periods
Verify that the `Set Posting Period` button is enabled after making the changes.
See Also
- Refer to: KBA 2598676 - Manage Posting Periods Authorization
- Refer to: KBA 3072643
Keywords
authorization, posting period restriction, adjustment period, ZCBR_GL_ACCOUNTANT_WO_ZAUG, ZBR_GL_ACCOUNTANT, SAP S/4HANA Cloud Public Edition, manage posting periods, access category, restriction types, unrestricted, restricted, set posting period button disabled, adjustment period posting , KBA , FI-FIO-GL-PER-2CL , Periodic Activities Applications in General Ledger (PubC) , Problem
SAP Knowledge Base Article - Public