SAP Knowledge Base Article - Public

3699011 - ADLS connection fails with "forbidden" error in Datasphere

Symptom

The connection type is Microsoft Azure Data Lake Storage Gen2. When validating connection, the error occurs:

-------------------------------------------------------------------------------------
Connection "xxx" couldn’t be established.
- Data flows can’t be used because of errors in the connection.
- Replication flows can’t be used because of errors in the connection.
- Remote tables are not supported.


Data Flows: Cause: Possible causes of error: Detailed error message (forbidden)
Replication Flows: Cause: Possible causes of error: Detailed error message (forbidden)

Correlation ID: xxxxxx
-------------------------------------------------------------------------------------

Environment

  • SAP Datasphere

  • Microsoft Azure Data Lake Storage Gen2

Reproducing the Issue

  1. Go to "Connections"
  2. Validate the Microsoft Azure Data Lake Storage Gen2 connection
  3. Connection validation fails with: "Data Flows: Cause: Possible causes of error: Detailed error message (forbidden)
    Replication Flows: Cause: Possible causes of error: Detailed error message (forbidden)"

Cause

The SAS token does not match the Root Path. 

Resolution

Ensure the SAS token is generated from the Root Path configured in the connection settings.

See Also

SAP Help - Microsoft Azure Data Lake Storage Gen2 Connections

Keywords

DWC, DS, DSP, ADLS, ADLV , KBA , DS-DI-CON , Connections , Problem

Product

SAP Datasphere all versions