Symptom
Employee encounters an error when attempting to switch to concurrent employment in the SAP SuccessFactors Mobile application.
Device Deactivation
It appears you don't have access to the mobile application. This device will be deactivated. Please contact your system administrator for more information.
We couldn't switch your employment, please try again or contact your system administrator.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Employee Central
Reproducing the Issue
- Log into Successfactors mobile application.
- Navigate to Settings >> Switch multiple active employments.
- Observe the error messages displayed.
Cause
The user (with main employment) has required permissions for mobile access.
But the user (with concurrent employment) has NO permission for mobile access.
Resolution
- Navigate to Admin Center > Manage Permission Roles.
- Edit the role for the user(with concurrent employment) requiring mobile access.
- Go to the "Add Permissions" section and search for "Mobile Access" under the "General User Permission" section.
- Check the box to enable the permission for mobile access.
- Save the role to apply changes.
See Also
KBA2088244 - How to Permission the SuccessFactors Mobile App Access? [SF MOB]
Switch Between Multiple Active Employments in SAP SuccessFactors Mobile | SAP Help Portal
Keywords
switch multiple active employments, device deactivation error, mobile access permission, concurrent employment error , KBA , LOD-SF-EC-MOB , Employee Central Mobile , LOD-SF-EC-RBP , Roles & Permissions (EC Core only) , LOD-SF-PLT-MOB , Mobile Issues , Problem
SAP Knowledge Base Article - Public