Symptom
Error validating a SFTP Cloud connection in SAP Datasphere:
Possible causes of error: Detailed error message (task timed out)
Environment
SAP Datasphere
Reproducing the Issue
- Validate the Generic SFTP connection in SAP Datasphere
- Observe the error message: "Cause: Possible causes of error: Detailed error message (task timed out)"
Cause
The SAP Datasphere IP address was not added to the allowlist of the external SFTP server, which is protected by a firewall.
Resolution
- Add the SAP Datasphere Replication Flow/Data Flow NAT IP address to the allowlist of the SFTP server. Refer to Finding SAP Datasphere IP addresses | SAP Help Portal for guidance on finding the SAP Datasphere IP address
- Validate the SFTP connection again to confirm resolution
Keywords
validation , KBA , DS-DI-CON , Connections , Problem
Product
SAP Datasphere all versions
SAP Knowledge Base Article - Public