SAP Knowledge Base Article - Public

3699537 - Blocked Accounts do not show in Agent Desktop Search

Symptom

Searching for an specific term in Agent Desktop Search brings different Account results when comparing it with the Accounts worklist.

Environment

  • SAP Service Cloud Version 2
  • SAP Service Cloud and SAP Sales Cloud Version 2

Reproducing the Issue

  1. Open Agent Desktop.
  2. Search for an specific term.
  3. Observe that a number of Accounts (i.e. 3 results) are displayed in the Agent Desktop search results.
  4. Open the Account Worklist.
  5. Perform the same search using the same term.
  6. Observe that a different number of accounts (i.e. 4 results) is displayed

Cause

Agent Desktop filters the search results to display only Accounts with the status "Active". The account missing from the Agent Desktop search results has the status "Blocked".

Resolution

  1. Verify the status of the accounts in the Account Worklist.
  2. Confirm whether the missing account(s) have a status other than "Active".
  3. Update the status of the blocked account(s) to "Active" if applicable.
  4. Perform the search again in the Agent Desktop to verify that the results match the Account Worklist.

Keywords

agent desktop, account worklist, search results, discrepancy, active accounts, blocked accounts, account status, search term, account service, filtering , KBA , CEC-CRM-AD , Agent desktop - live channels , Problem

Product

SAP Sales Cloud and SAP Service Cloud Version 2 all versions ; SAP Service Cloud Version 2 all versions